Ticket #21 (accepted defect)

Opened 5 years ago

Last modified 4 years ago

userfile sharing fails during certain NAT situations

Reported by: Darkreap1, simple Owned by: pseudo
Priority: minor Milestone: 1.8.0
Component: Module: share.mod Version: 1.8.0 CVS
Keywords: Cc:

Description

Created an attachment (id=94) [details]
userfile sharing patch

Bots should be connecting to the bot address just like they do for regular
linking. Instead they are exchanging IP addresses which can get messy if you
use nat-ip, this problem has existed since I started using 1.3. Basically if
you have a bot on your lan, sharing with other bots on your lan, and also
sharing with bots on the internet, its going to fail unless you have some
firewall rules to work around it.

crappy patch included

Attachments

share-nat-fix.diff Download (1.5 KB) - added by pseudo 5 years ago.

Change History

Changed 5 years ago by pseudo

comment:1 Changed 5 years ago by simple

  • Milestone set to 1.6.20

comment:2 Changed 5 years ago by simple

  • Reporter changed from Dan to Darkreap1/simple

comment:3 Changed 5 years ago by simple

  • Reporter changed from Darkreap1/simple to Darkreap1, simple

comment:4 Changed 4 years ago by pseudo

  • Component changed from Core to Module: share.mod
  • Milestone changed from 1.6.20 to 1.6.21

comment:5 Changed 4 years ago by pseudo

  • Owner set to pseudo
  • Priority changed from major to minor
  • Version changed from 1.6.20 to 1.8.0 CVS
  • Status changed from new to accepted
Note: See TracTickets for help on using tickets.